From ApCoCoAWiki
Revision as of 10:24, 16 December 2010 by (talk)

To report a bug, add a line describing the problem and how to reproduce it in the "Open" section.


  • Latte tests fail on Standalone: Error massage is: TestLatte06(): FAILURE! TODO: Some error message!. EU
  • Unpacking win standalone, starting and reusing already existing projec raises error "ApCoCoA could not be started. Reason: The given ApCoCoA executable does not exist.". In the preferences, the interpreter install is deleted when opening the preferences dialog. Also every time you start it you need a new workspace. EU
  • ApCoCoAServer throws the error/warning: Trying to launch application: /home/garak/ApCoCoA-1.6.0/plugins/org.apcocoa.contribution.linux.x86.gtk.fragment_1.6.0.201012151632/os/linux/apcocoa/Glpk/bin/glpsol in path ' ' (x86 Linux) SN
    • ST-2010-12-16: This is the usual info when launching stuff by the server. Maybe the empty path is irritating. Are there any errors after this line?
  • The input line <-> closes the ApCoCoA Session after printing two parse errors. (x86 Linux Moccha) SN
  • ApCoCoAServer & ApCoCoAQT crashed with 'invalid pointer' when I tried to use (missing) GNUPlot: Trying to launch application: /home/garak/ApCoCoA-1.6.0/gnuplot/bin/wgnuplot in path' ' No path is given. (x86 Linux QT) SN
    • ST-2010-12-16: We have to discuss a standard way of handling missing external binaries (which we do not want to supply for some platforms, like gnuplot on linux).


  • Latte tests fail on Linux/Mac. Latte build seems to be broken. Linux 32/64, Mac, SK
    • SK-2010-12-15: Update: the tests only fail if called from Moccha.
    • SK-2010-12-15: Update: fixed on Linux platforms. Mac platform will be fixed shortly (I guess).
  • Naming of "Default Interpreter".
  • ApCoCoA default interpreter missing. After an update via the Eclipse update mechanism the default ApCoCoA interpreter is missing and it is not possible to add a new interpreter other than 'cocoa_text'. Linux 32 (Update), SK
    • ST-2010-12-16: Problem is a bug in the DLTK, which forces us to use lower case only names for the ApCoCoA executable.
    • SK-2010-12-15: Temporary workaround to get it working: rename 'ApCoCoAText' to 'cocoa_text' and select it as interpreter.
    • (?) Some issue with the downloaded version (ApCoCoA-1.6.0-20101215-1631-linux.gtk.x86.tar.gz) SN
  • Moccha uses some Java-1.6 specifics s.a. String.isEmpty() which shoule be avoided due to 1.5 compatibility.
    • ST-2010-12-15: Fixed for the problem in question, however we need to check all files for this issue. However, we need a pure 1.5 installation for this.
  • Opening of library files broken. Add new project, go to libraries, try to open. Instead of the content, an error message is displayed in the editor window. MacOS X, ST


  • The test suit is not running successfully in standalone at WindowsXP. When I run $apcocoa/ts/aunit.RunTests(); I get the following error message: TestTemplate01(): FAILURE! Unknown operator, TestTemplate02(): SUCCESS!. EU
    • Did you follow the instructions and execute both commands
  • Two functions IMXLSolve and IMNLASolve are missing in the documentation of the package CharP.
    • TS-2010-12-16: The two functions will be added today.
  • The Alias for the package CharP is also not working The error message displayed is "ERROR: Non local alias CharP CONTEXT: CharP.XLSolve(F).". EU
    • ST-2010-12-16: Fixed, alias was still Char2.
  • "My" functions G2V.G2VAlgorithm(...) is missing in tab completion. Am I missing something in my .cpkg? SN
    • ST-2010-12-16: Corresponding entry in aliases.coc was missing, it's fixed, please check if it is working.
  • Inconvenience While restarting ApCoCoA with Moccha. While working in Eclips GUI(Moccha) when we restart ApCoCoA with restart button then it asks for saving the unsaved file if there is any. It would be nice if it do not asks for it. Moccha(Windows), EU
    • ST-2010-12-14: There is an option Save required dirty editors before launching under Preferences > Run/Debug > Launchin, which you can set to Always, Never or Prompt.
  • '#######VERSIONSTRING#######' not replaced. The string '#######VERSIONSTRING#######' is not being replaced but should be replaced with current version number. Linux 32 (Update), SK
  • ApCoCoAServer doesn't lauch correctly for ApCoCoA GUI in Mac.
    • ST-2010-12-15: ApCoCoAServer was compiled on 10.6, the problem occured on a 10.5 machine. After recompiling needed libraries and server with cxx-flags "-isysroot /Developer/SDKs/MacOSX10.5.sdk -mmacosx-version-min=10.5" it is now exectuable again on the 10.5 machine.
  • GLPK tests fail on Linux with GLPK > 4.34. Due to a change in the input file format for glpsol. Linux 32/64, SK
    • SK-2010-12-15: Will be fixed after the release.
  • The Linux *.zip-files can not be extracted. Renaming to *.tar.gz solves the problem, TS
    • ST-2010-12-15: Fixed, files are now named correctly.
  • Wrong about text "1.5.1"
    • ST-2010-12-15: OK.
  • In the ApCoCoA preferences dialog there is a typo in "Choose method to start CoCoA". It states "spawner withot PTY".
    • ST-2010-12-15: OK.
  • At line 770 in the package CharP there is a typo error i.e. "EndIf;8". Please remove 8 from there. EU.
    • SK-2010-12-15: Fixed.