Difference between revisions of "Category:CoCoA4"

From CoCoAWiki
(describe the 3 different clients)
m (current release 4.5.1)
Line 1: Line 1:
 
==About==
 
==About==
  
CoCoA 4 is no longer in development, but is still being maintained. The current release is CoCoA 4.4.
+
CoCoA 4 is no longer in development, but is still being maintained. The current release is CoCoA 4.5.1.
 
It can be downloaded at  
 
It can be downloaded at  
  
 
* [http://cocoa.dima.unige.it/download/ http://cocoa.dima.unige.it/download/]
 
* [http://cocoa.dima.unige.it/download/ http://cocoa.dima.unige.it/download/]
* mirrors?
+
* [ftp://ftp.reed.edu/mirrors/cocoa/]
  
CoCoA 4 uses and is programmed in [[:Category:CoCoAL|CoCoAL]].
+
CoCoA 4 uses and is programmed in [[:Category:CoCoAL|CoCoALanguage]].
  
 
==Interfaces==
 
==Interfaces==

Revision as of 14:09, 29 November 2005

About

CoCoA 4 is no longer in development, but is still being maintained. The current release is CoCoA 4.5.1. It can be downloaded at

CoCoA 4 uses and is programmed in CoCoALanguage.

Interfaces

There are three different CoCoA 4 clients:

  • cocoa-text: provides a bare bones interface. Most users won't use this version, but it can be useful when running computations in batch mode on a shell.
  • Emacs-plugin: provides an Emacs interfaces that is a lot more comfortable than the bare bones cocoa-text. This client is more popular with the Linux/MacOSX/Unix crowd.
  • cocoa-qt: provides a GUI written in Qt, multiple input windows and integrated html-help. This client is more popular with the Windows crowd.

All clients use the same computing engince so you should get the same result regardless of the client. On certain corner cases the clients show different behauviour, i.e. very long strings (2Megabytes+) seem to upset certain version of Emacs, while the Qt-client can handle strings pretty much the size of your RAM and then some. Each client has its own limitations and strength, so use the one that you are comfortable with and does the job for you.

Supported Plattforms

At the moment the following operating systems are supported:

  • MacOSX
  • PowerPC running LinuxPPC
  • Pc running Linux
  • Pc running Windows (only version 4.3 or 4.4, emacs interface)
  • Sun (version 4.2, emacs interface)
  • DEC Alpha workstations (version 4.2, emacs interface)
  • ARM (version 4.2, emacs interface)

For some more information on currently available releases of CoCoA 4.4 check out CoCoA4 Builds.