HowTo:Install and Work with the Eclipse GUI

From CoCoAWiki
Revision as of 12:25, 7 June 2016 by Kriegl (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Introduction

This HowTo shows you how to get started with the new Eclipse Graphical User Interface (GUI) for (Ap)CoCoA.

Edit June 2016: Please note that there are compatibility problems with Eclipse versions 3.7 and newer. Since Eclipse 3.6 or older versions are no longer supported with updates, we recommend to use the Standalone Versions of (Ap)CoCoA until the compatibility problems have been fixed.

Prerequisites

  • A current Java runtime environment
  • Eclipse If you are new to Eclipse, the variety of different packages to choose from may be confusing. However, for using ApCoCoA it does not matter which package you choose and we therefore recommend to choose the smallest one (which currently is the Eclipse IDE for C/C++ Developers)
 'Note' In order to benefit from the possibilities offered by the Eclipse update mechanism, we highly recommend to switch to Eclipse Galileo or later.
 If you are using Eclipse 3.7 (Indigo) make sure to contact only the ApCoCoA update site, as described below!

Installation

Installing and Running Eclipse

After you have downloaded one of the Eclipse packages (e.g. the Eclipse IDE for C/C++ Developers), unpack the package, go to the newly created folder eclipse and start the eclipse executable. That's all. You will next be asked to provide a workspace directory. This is where all your projects and (ApCoCoA) files will be stored. If unsure, just take the suggested directory. When you start Eclipse for the first time, you are presented with the welcome screen, which you can just close.

01 welcome.png

If you have downloaded the Eclipse IDE for C/C++ Developers, Eclipse is in the C/C++ perspective (a perspective defines the arrangement of the different visual elements such as the editor, navigators,...) which is the starting point for this tutorial.

02 start eclipse.png

Installing the Plugin

One of the really nice things in Eclipse is the ease of installing and updating plugins, i.e. extensions of the Eclipse platform that add new features and functionality to Eclipse, just as the GUI plugin does. To install the ApCoCoA GUI plugin, follow these steps:

  • In the menu bar, click Help > Install New Software...
  • Next, enter at Work with: the URL http://www.apcocoa.org/updatesite/ and click Add...
  • Just click Ok on the dialog that opens now, a name is optional for your new update site.
  • Now you should see the following picture on your screen.
    03 install dialog.png
  • Then check Apcocoa GUI and the feature appropiate to your platform (e.g. Linux 32-Bit). Click Next>.
 NOTE: With the combination Eclipse 3.7 (Indigo) + ApCoCoA 1.7 and before, disable "Contact all updatesites ..."! 
  • Eclipse then looks up the plugins that have to be installed and presents you a review and confirm page. Click Next>.
    04 review dialog.png
  • Accept the license agreement and click Finish.
    05 accept license.png
  • Next you will be asked to restart the Eclipse platform which is recommended.
  • Finally, you should see some new additions in the menu and tool bars.

    New Additions.jpg


You are now ready to set up and use ApCoCoA with Eclipse.

First Steps

Configure Eclipse

In the current alpha release, neither ApCoCoA executables are not packed with the Eclipse plugin yet. The plugin does also not check for installed ApCoCoA executables. Therefore, the paths have to be configured manually as follows.

  • Go to Window > Preferences > ApCoCoA Preferences
  • Set paths to the ApCoCoA command line executable and ApCoCoA Server or BBF Server and click OK
    06 setting apcocoa paths.png
  • Verify the settings by starting ApCoCoA, clicking on the (Re)start ApCoCoA Process button ApCoCoA Restart Button.jpg. In the console view you can see now the ApCoCoA greeting message.
    Greeting Message.jpg

Create a new Project

All work done within Eclipse is organized into projects. To create a new project

  • Go to File > New > Project ...
    07 apcocoa project.png
  • In the Project Wizard, select ApCoCoA Project in the Other category and click Next.
  • Name the project GUI Tutorial and click Finish.
    New Project Name.jpg
  • If you are not already in the ApCoCoA Perspective, Eclipse asks you now if you want to switch to it. Accept this.
  • In the Navigator on the left side you can now see the newly created project, moreover, Eclipse created a new folder in the workspace directory.
    08 eclipse navigator.png

Create and use an (interactive) Editor Window

To enter (Ap)CoCoA commands and programs, you need an editor window. Within the (Ap)CoCoA QT-GUI, there are two kinds of editor windows or, more specific, editor tabs: a) the interactive default editor tab, where you enter commands but usually do not edit programs (since the window is cleared after sending its content to (Ap)CoCoA); and (b) the "persistent" editor tabs, where you edit your programs. The interactive behavior is mimicked in Eclipse if you create a special "file" with the extension .aco:

  • Right-click on the GUI Tutorial project and select New > File.
  • Create a new file e.g. named interactive.aco and click Finish.
    New File Interactive.jpg
  • Type a sample command in the new editor window and send it to ApCoCoA, typing Ctrl+Enter.
    Hello World.jpg
  • The editor windows content is then added to the history and the editor is cleared. As in the CoCoA QT-GUI, you can navigate through the histroy with Alt+Left and Alt+Right.
  • Note that the content of interactive editors is not saved to disk!
 Tip: If you are uncomfortable with the key bindings, you can simply change them in the General Preferences (Window > Preferences > General > Keys).

To create a "normal" editor window, create a file with the extension .coc or .cpkg. Files with this extension are associated to ApCoCoA editors with all their features (syntax coloring, sending content to the ApCoCoA process via Enter+Enter,...).

Getting Help

To access the ApCoCoA Help go to Help > Help Contents. On the left side you find the ApCoCoA Handbook.
ApCoCoA Help.jpg

Further Topics

Working with the ApCoCoA / BBF Server

To start the ApCoCoA Server, click on the button Start ApCoCoA Server Start ApCoCoA Server.jpg.

Since there is initially only one console view that would be shared by both the server and the cocoa process it is more convenient to

  • pin the ApCoCoA console
    Console Pin.jpg
  • open a second console view
    Open Console View.jpg
  • rearrange the two console views (see below).

Adjust the Appearance

In Eclipse, it is possible to rearrange the visual components in (almost) any way you like via drag & drop.

GUI Rearrangement.jpg

Known Issues

  • If you update the Eclipse GUI to 0.1.2 you should recheck your preferences and make sure that the CoCoA Interpreter / ApCoCoA Server are the ones delivered from the updatesite.